Continued Monitoring- ISP- Wind outages
Incident Report for Preferred IT Solutions
Resolved
We have received notifications that all impacts have been resolved. We will continue to monitor for outages due to inclement weather. Please report all outages to service@preferreditsolutions.com.
Posted Apr 03, 2021 - 09:02 EDT
Update
We've received numerous ISP outage reports from our Eastern Ohio and far Western Pennsylvania customers throughout Friday April 4th 2021. ISPs reported are: Armstrong, Comcast and Spectrum. Please contact service@preferreditsolutions.com with any additional outages.
Posted Apr 02, 2021 - 13:43 EDT
Investigating
We're currently monitoring outages due to high winds. Although very few of our customers have reported outages, there have been isolated incidents. Please report all outages to service@preferreditsolutions.com.
Posted Mar 30, 2021 - 17:48 EDT
This incident affected: Internet Service Providers (ISP) (Comcast Internet, Spectrum Internet, Verizon Internet, Armstrong Internet, AT&T Internet).