Comcast Internet Outage
Incident Report for Preferred IT Solutions
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 16:45 EDT
Monitoring
Comcast currently having intermittent network outages due to weather, expect network issues and loss of internet.
Posted Jun 21, 2021 - 10:38 EDT
Investigating
Comcast currently having intermittent network outages due to weather, expect network issues and loss of internet.
Posted Jun 21, 2021 - 10:37 EDT
This incident affected: Internet Service Providers (ISP) (Comcast Internet).