Phone System Outage
Incident Report for Preferred IT Solutions
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 16:08 EST
Monitoring
We are starting to see services restored and are continuing to monitor the situation.
Posted Nov 12, 2021 - 15:14 EST
Update
We are continuing to investigate this issue.
Posted Nov 12, 2021 - 14:49 EST
Update
Update - We are continuing to investigate this issue
Posted Nov 12, 2021 - 13:51 EST
Investigating
Investigating - Multiple customers are experience major disruptions with Preferred IT phone systems. Incident is being investigated as a top priority.
Posted Nov 12, 2021 - 13:50 EST
This incident affected: Phone System (Preferred IT Solutions 3CX Cloud Status).