3CX Intermediate Issues
Incident Report for Preferred IT Solutions
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 10:14 EDT
Monitoring
3CX is currently experiencing intermediate issues. The web conferencing bridge is currently unavailable. We are monitoring and will update as this progresses.
Posted Sep 24, 2021 - 14:23 EDT
This incident affected: Phone System (Preferred IT Solutions 3CX Cloud Status).