Verizon Communication Issues
Incident Report for Preferred IT Solutions
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 14:05 EDT
Update
We are continuing to work for a fix to this problem.
Posted Jun 20, 2022 - 08:39 EDT
Identified
Verizon is having telecommunications issues that are resulting in static calls. This is an issue that Verizon is attempting to resolve, but we have no ETA of when they'll implement a resolution. Our network is fully operational and is functioning correctly. We will keep you updated of any changes as we receive more information from Verizon.
Posted Jun 17, 2022 - 16:37 EDT
This incident affected: Internet Service Providers (ISP) (Verizon Internet).